텍스트 파일에서 여러 줄 추출 [닫기]

텍스트 파일에서 여러 줄 추출 [닫기]

원천:

!
hostname RTR-1
!
boot-start-marker
boot-end-marker
!
logging buffered 64000 informational
no logging console
!
interface FastEthernet0/0
 description LAN
 ip address 172.16.29.250 255.255.255.0
 ip helper-address 172.18.1.130
 ip helper-address 172.18.1.127
 ip tcp adjust-mss 1350
 speed 100
 full-duplex
!
line vty 0 4
 exec-timeout 30 0
 transport input telnet ssh
 transport output telnet ssh
!
end

산출:

interface FastEthernet0/0
 ip helper-address 172.18.1.130
 ip helper-address 172.18.1.127

또는:

!
hostname RTR-1
!
boot-start-marker
boot-end-marker
!
logging buffered 64000 informational
no logging console
!
interface Vlan1
 description LAN
 ip address 172.16.29.250 255.255.255.0
 ip helper-address 172.18.1.130
 ip helper-address 172.18.1.127
 ip tcp adjust-mss 1350
 speed 100
 full-duplex
!
line vty 0 4
 exec-timeout 30 0
 transport input telnet ssh
 transport output telnet ssh
!
end

산출:

interface Vlan1
 ip helper-address 172.18.1.130
 ip helper-address 172.18.1.127

구성 명령 "helper-address"에 대한 인터페이스 이름을 추출하고 싶습니다.

위의 소스 출력은 파일에 저장되거나 라이브 라우터에서 직접 추출될 수 있습니다.

답변1

grep "interface\|helper" source.file

작업이 그렇게 어려운지 여기에서 물어보세요.

업데이트: OS에 존재하지 않는 경우 grep위 스크립트를 shell-bultins로 바꿀 수 있습니다.

while read
do
  case "$REPLY" in
  *interface*) echo "$REPLY" ;;
  *helper*) echo "$REPLY" ;;
  esac
done < source.file

관련 정보